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Exercise 1: VPN 
 

Scenario 
 
This exercise demonstrates how to create VPN connectivity between VPN Server and VPN 
Client. The exercise use Windows 2000 Server Routing and Remote Access service to configure 
the computer becomes a VPN Server. It uses a Windows 2000 Professional as a VPN Client to 
connect to the VPN Server. 
 

Detail Steps to perform exercise: 
 
Start the VPCs one by one. 
 

1. Run Microsoft Virtual PC 
2. In the Virtual PC Console, start the w2ksrv01. Logon using administrator as username, 

P@ssw0rd as password. 
3. In the Virtual PC Console, start the w2ksrv02. Logon using administrator as username, 

P@ssw0rd as password. 
4. In the Virtual PC Console, start the vpnclient. Logon using administrator as username, 

P@ssw0rd as password. 
 
Enable the VPN Server 
 

1. Switch to w2ksrv01, click Start > Programs > Accessories > Command Prompt. 
2. In the Command Prompt window, type in IPCONFIG. Note that there are two IP 

Addresses have been assigned to the computer. The 192.168.18.1 is used for Internal 
LAN and 192.168.23.1 is used for External, which is the Internet. 

3. Close the Command Prompt window. 
4. Click Start > Programs > Administrative Tools > Routing and Remote Access. 
5. In the Routing and Remote Access Console, right click SRV01 (Local) in the console 

tree and select Configure and Enable Routing and Remote Access. 
6. In the Routing and Remote Access Server Setup Wizard, click Next. 
7. In the Common Configurations screen, select Virtual private network (VPN) server and 

click Next. 
8. In the Remote Client Protocols window, click Next. 
9. In the Internet Connection window, select External NIC and click Next. 
10. In the IP Address Assignment screen, select From a specified range of addresses and 

click Next. 
11. In the Address Range Assignment dialog box, click New. 
12. In the New Address Range dialog box, enter 192.168.18.101 in the Start IP Address 

prompt. In the End IP address prompt, enter 192.168.18.110. 
13. Click OK to confirm and close the New Address Range dialog box. 
14. In the Address Range Assignment dialog box, click Next. 
15. In the Managing Multiple Remote Access Servers window, select No, I don’t want to set 

up this server to use RADIUS now and click Next. 
16. In the Completing the Routing and Remote Access Server Setup Wizard window, click 

Finish. 
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17. If there is a dialog box appear stated that ‘To support the relaying of DHCP 
messages….’, press OK to close it. 

18. After the RRAS service is started, expand the SRV01 (Local) folder in the console tree. 
19. Click the Ports folder on the console tree to see available VPN-ports in the right hand 

side. 
20. Click on Remote Access Clients (0) and aware that there is no remote access client at 

this moment. 
21. Leave the RRAS Console open. 

 
Enable Users can dial-in remotely 
 

1. In the w2ksrv01 VPC, click Start > Programs > Administrative Tools > Active Directory 
Users and Computers. 

2. In the Active Directory Users and Computers console, click on Users container in the 
console tree. 

3. Look for Administrator user account on the detail pane and double click to open the 
Administrator Properties dialog box. 

4. Go to Dial-In tab in the Administrator Properties dialog box. 
5. In the Remote Access Permission (Dial-in or VPN) area, select Allow access. 
6. Click OK to close the Administrator Properties dialog box. 
7. Close the Active Directory Users and Computers Console 

 
Configure VPN Client 
 

1. Go to vpnclient VPC. Click Start > Programs > Accessories > Windows Explorer. 
2. Go to address bar on Windows Explorer. Type in \\SRV01 and press Enter. 
3. After a while, an error will be displayed. Press OK to close the error dialog box. 
4. Leave the Windows Explorer window open. 
5. Click Start > Programs > Accessories > Command Prompt. 
6. On the Command Prompt window, type in IPCONFIG and verify that there is only one 

IP Address assigned to this computer. 
7. Leave the Command Prompt window open. 
8. Click Start > Settings > Network and Dial-up Connections. 
9. On the Network and Dial-up Connections dialog box, double click Make New 

Connection 
10. On the Welcome to the Network Connection Wizard dialog box, click Next. 
11. On the Network Connection Type window, select Connect to a private network through 

the Internet and click Next. 
12. On the Destination Address window, type in 192.168.23.1 and click Next. 
13. In the Connection Availability window, click Next. 
14. In the Completing the Network Connection Wizard window, type in ‘Welkin Office’ and 

click Finish. 
15. A Connect Welkin Office dialog will be displayed. Close it by click on Cancel button. 
16. Switch back to Network and Dial-up connections dialog box, you will see a new icon 

named Welkin Office is added. 
17. Double click Welkin Office icon. On the Connect Welkin Office dialog box, make sure 

the username is Administrator and the password is P@ssw0rd. 
18. Press Connect after input username and password. 
19. In the Connection Complete dialog box, click OK. 
20. Switch back to Command Prompt window, type IPCONFIG and confirm there are two 

IP Addresses. The one with 192.168.18.x is assigned from the VPN Server. 
21. Switch back to Windows Explorer. In the address bar, type \\srv01 and press Enter. 
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22. srv01’s share resources will be displayed after a while. 
23. In the address bar, type \\192.168.18.2\userdata and press enter. 
24. With appropriate permission, you can access the shared folder in 192.168.18.2 (srv02) 

and edit those files. 
 
Review VPN Connectivity in VPN Server. 
 

1. Switch to w2ksrv01 VPC. Go to Routing and Remote Access Console. 
2. Right Click SRV01 (Local) and select Refresh. 
3. Click on Ports in the console tree and look for an Active VPN port in detail pane. 
4. Double click on the Active port to review the information. 
5. After finished review the port status. Close the dialog box. 
6. Click on Remote Access Clients (1) on console tree. Note that there is an connection 

entry on the right hand side. 
7. Double click on the entry and review the information on the dialog box. 
8. After completed review the Status, close the dialog box. 

 
Close all VPC 
 

1. Switch all VPCs to Window Mode by using Right Alt+Enter if they are in Full Screen 
Mode. 

2. Click Action in the VPC Pull down menu. 
3. Click Close. 
4. In the Close Dialog Box, select Turn off and delete changes. Click OK. 

 
 
Review 
 

The procedures demonstrate how to setup and configure a VPN Server by using 
Windows 2000 Server. It also demonstrates how to configure the VPN Client. 



Page 4 

Exercise 2: Install and Configure a Certificate to Web Server 
 

Scenario 
 
You want to configure a Web Server to use SSL connection. You have to request for a 
certificate from a Certificate Authority and install it in the Web Server, and then configure the 
Web Server to use SSL. You have to test the connection from a client computer using Internet 
Explorer. 
 
 

Detail Steps to perform exercise: 
 
Start the VPCs one by one. 
 

1. Run Microsoft Virtual PC 
2. In the Virtual PC Console, start the w2ksrv01. Logon using administrator as username, 

P@ssw0rd as password. 
3. In the Virtual PC Console, start the w2ksrv02. Logon using administrator as username, 

P@ssw0rd as password. 
4. In the Virtual PC Console, start the w2kp01. Logon using administrator as username, 

P@ssw0rd as password. 
 
Create a Sample Main Page on IIS 
 

1. In w2ksrv02, run notepad in Start, All Programs, Accessories menu. 
2. In the Notepad windows, type in ‘This is Main Page of w2ksrv02 Web Server’. 
3. Click File, Save in the pull down menu. 
4. Change the save in location to C:\inetpub\wwwroot folder. 
5. Save the file as name : main.txt. Close the notepad program. 
6. Start Windows Explorer from the Start, All Program, Accessories menu. 
7. Navigate to C:\inetpub\wwwroot folder 
8. Verify the main.txt is in C:\inetpub\wwwroot folder. 

 
Change the Default Web Document for Web Server 
 

1. In w2ksrv02, click Start button, select Administrative Tools, click on Internet Services 
Manager. 

2. Expand Internet Information Services, *srv02, Default Web Site in the Console Tree. 
3. Right Click the Default Web Site in the Console Tree and select Properties. 
4. In the Default Web Site Properties dialog box, select Documents tab. 
5. Click Add Button in the Enable Default Document section. 
6. In the Add Default Document Page dialog box, type in main.txt and click OK. 
7. In the Default Web Site Properties dialog box, highlight main.txt and click Move Up 

four times to move main.txt to the top position in the list. 
8. Click OK to close the Default Web Site Properties dialog box. 
9. Click OK to confirm in the Inheritance Overrides dialog box. 

 
Test the Connectivity of Web Server w2ksrv02 
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1. Go to w2kp01 VPC, start Internet Explorer. 
2. In the Address bar, type in http://srv02 and press Enter. 
3. Verify that the main.txt content is displayed on the Internet Explorer successfully. 
4. Close the Internet Explorer. 

 
Review the Certificate Store in Certificate Server 
 

1. Go to w2ksrv01, click Start, Programs, Administrative Tools and Certification Authority. 
2. Expand W2K Enterprise Root CA. 
3. Select Issued Certificates folder in the console tree, review the issued certificate in right 

hand side. 
 
 
Request a Web Server Certificate. 
 

1. Go to w2ksrv02, in the Internet Information Services Console. Right Click the Default 
Web Site in the Console Tree and select Properties. 

2. In the Default Web Site Properties dialog box, go to Directory Security tab. 
3. In the Secure communications section, click Server Certificate button. 
4. In the Welcome to the Web Server Certificate Wizard window, click Next. 
5. In the IIS Certificate Wizard window, select Create a new certificate and click Next. 
6. In the Delayed or Immediate Request dialog box, verify ‘Send the request immediately 

to an online certification authority’ is selected and click Next. 
7. In the Name prompt, type in ‘w2ksrv02 Web Server’, click Next. 
8. In the Organization prompt, type in ‘Welkin Systems Limited’. 
9. In the Organizational unit prompt, type in ‘IT’. Click Next. 
10. In the Common name prompt, click Next. 
11. In the Country/Region combo box, select HK. 
12. In the State/province combox box, type in GD.  
13. In the City/Locality prompt, type in ‘Hong Kong’. Click Next. 
14. In the Choose a Certification Authority dialog box, click Next. 
15. In the Certificate Request Submission dialog box, review the summary and click Next. 
16. In the Completing the Web Server Certificate Wizard window, click Finish to complete 

the procedure. 
17. Click the View Certificate button on Secure communications area in Default Web Site 

Properties dialog box. Review the certificate. 
18. Click OK to close the certificate window. 
19. In the Default Web Site Properties window, click Edit button in the Secure 

communications area. 
20. In the Secure Communications window, click require secure channel (SSL) check box to 

select it. 
21. Click OK to close the Secure Communications dialog window. 
22. Click OK to close the Default Web Site Properties window. 
23. Click OK in the Inheritance Overrides dialog box. 

 
 
Review the Certificate Store in Certificate Server 
 

1. Go to w2ksrv01. 
2. In the Certification Authority console, right click the Issued Certificates folder and click 

Refresh. 
3. Review the detail pane and a new certificate has been issued to srv02. 
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Test the Connectivity of Web Server w2ksrv02 
 

1. Go to w2kp01 VPC, start Internet Explorer. 
2. In the Address bar, type in http://srv02 and press Enter. 
3. Verify that you have a error message displayed on screen. 
4. Change the address to https://srv02 and press Enter. 
5. In the Security Alert window, click OK. 
6. Verify that the page is displayed successfully. 
7. Double click the Lock Icon on the bottom right corner to view the Computer Certificate. 
8. Close the certificate after completed reviewing. 

 
Close all VPC 
 

1. Switch all VPCs to Window Mode by using Right Alt+Enter if they are in Full Screen 
Mode. 

2. Click Action in the VPC Pull down menu. 
3. Click Close. 
4. In the Close Dialog Box, select Turn off and delete changes. Click OK. 

 
 
Review 
 
The procedures demonstrate how to request a certificate from a Certificate Authority and how to 
implement the certificate in a Web Server. There are numerous methods to submit the request to 
a CA, the method demonstrated here is based on Microsoft Windows Network environment only. 
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Exercise 3: Spying Tools 

Scenario 
 
This exercise demonstrates how to use spying tool which can capture computer users’ activity 
and save in a log file. 
 
Hacker may use various methods to look for vulnerability in a computer. For example, a Port 
Scanning Tools can scan for opened port in one or range of computers in a subnet. After hacker 
penetrate into the computer, spying software can be installed on that victim computer without 
any hints. Spying tools may capture user’s typing in the computer and saved in a log file. Hacker 
can come back to collect the log file and user’s privacy is disclosed eventually. 
 
The following exercise only demonstrates how to use a spying tool to capture user activity. The 
way to penetrate into victim’s computer is out of the syllabus here. 
 

Detail Steps to perform exercise: 
 
Start the VPCs one by one. 
 

1. Run Microsoft Virtual PC 
2. In the Virtual PC Console, start the w2ksrv01. Logon using administrator as username, 

P@ssw0rd as password. 
3. In the Virtual PC Console, start the w2kp01. Logon using administrator as username, 

P@ssw0rd as password. 
 
 
Install Spying Software 
 

1. Go to w2kp01. Close all programs except Windows Explorer. 
2. Navigate to C:\TOOLS\INTERNET SPY folder. 
3. On the right hand side, double click the Internetspy-setup.exe program. 
4. In the Internet Spy, Free Edition windows. Click Install button. 
5. After the installation is completed, click the Close button. 
6. Internet Explorer program will be opened after the installation, close it. 
7. There is a small icon appear next to your system clock.  
8. Move your mouse pointer on top of it and you will see a message displayed: 

SpyArsenal.com - Internet Spy v1.20. 
9. Right click on this icon, select Hide icon from the context menu. 
10. In the SpyArsenal.com – Internet Spy v1.20 dialog box. Click OK to close the message 

box. 
11. Start Internet Explorer. In the address bar, type in http://srv01 and press Enter. 
12. In the address bar, type in http://www.welkin.com.hk and press Enter. 
13. Do not need to worry about there is nothing displayed on screen because this Virtual PC 

is blocked and cannot reach Internet. 
14. Press Ctrl-Shift-Alt-I simultaneously to display the SpyArsenal.com – Internet Spy v1.20 

icon in the System Tray area again. 
15. Right click on the SpyArsenal.com – Internet Spy v1.20 icon in the System Tray. In the 

context menu, select View Log. 
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16. Review the log and see everything you typed in the Internet Explorer window will be 
captured and saved in the log. 

 
 
Install Key Logging Software 
 

1. Go to w2kp01. Close all programs except Windows Explorer. 
2. Navigate to C:\TOOLS\INTERNET SPY\BONUS!!! folder. 
3. On the right hand side, double click the FamilyKeyLogger-setup.exe program. 
4. In the Family Keylogger v2.83: License Agreement windows. Click I Agree button. 
5. In the Family Keylogger v2.83: Installation Options windows. Click Next button. 
6. In the Family Keylogger v2.83: Installation Folder windows. Click Install button. 
7. In the Family Keylogger v2.83: Completed windows. Click Close button. 
8. Internet Explorer program will be opened after the installation, close it. 
9. There is a small icon appear next to your system clock.  
10. Move your mouse pointer on top of it and you will see a message displayed: Family 

Keylogger v2.83. 
11. Right click on this icon, select Hide icon from the context menu. 
12. In the Family Keylogger v2.83 dialog box. Click OK to close the message box. 
13. Start Internet Explorer. In the address bar, type in http://srv01 and press Enter. 
14. In the address bar, type in http://www.welkin.com.hk and press Enter. 
15. Do not need to worry about there is nothing displayed on screen because this Virtual PC 

is blocked and cannot reach Internet. 
16. Press Start and select Run. Type in Notepad in the Open: prompt. 
17. Type in ‘I typed something in notepad.’ 
18. Using File > Save to save the file to My Documents folder and name it File1.txt. 
19. Close the Notepad program. 
20. Press Ctrl-Shift-Alt-F simultaneously to display the Family Keylogger v2.83 icon in the 

System Tray area again. 
21. Right click on the Family Keylogger v2.83 icon in the System Tray. In the context menu, 

select View Log. 
22. Review the log and see the log will capture everything about username, date, time, 

program and keystroke activities. 
 
Note: This exercise demonstrates how Spying software captures everything you typed in a 
browser or any application program. The software can become hidden without notice by user. 
Consider what happen if your usernames and passwords on Web Based Email, Internet Banking 
service, etc are captured and to be collected by a hacker. 
 
Close all VPC 
 

1. Switch all VPCs to Window Mode by using Right Alt+Enter if they are in Full Screen 
Mode. 

2. Click Action in the VPC Pull down menu. 
3. Click Close. 
4. In the Close Dialog Box, select Turn off and delete changes. Click OK. 
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Exercise 4a: Folder Sharing in Peer-To-Peer Network 
 

Scenario 
 
You have two PCs and want to share files between these two PCs. 
 

Detail Steps to perform exercise: 
 
This exercise requires two partners. Each partner must use the IPCONFIG command to obtain 
the computer’s IP Address before proceed the exercise. 
 
The partners determine which one is PC1 and which one is PC2. After obtained the IP Address, 
substitute the PC1 and PC2 names with your computer’s IP Address in the following steps. 
 
 
Create a folder share in PC1 
 
1. In PC1, run Windows Explorer. 
2. Navigate to C:\. 
3. Create a folder named DATA under C:\. 
4. Right Click on the new created Folder and select Sharing and Security… 
5. Check the Share this folder option button in the Data Properties dialog box. 
6. You don’t have to change the share name. Click Permissions button. 
7. Select Allow Full Control check box. 
8. Click OK to return to previous dialog box. 
9. In the Data Properties dialog box, select Security tab. 
10. Review the current setting on Security tab. 
11. Click OK to close the Data Properties dialog box. 
 
 
Connect to the share folder in PC1 from PC2 
 
1. In PC2, run Windows Explorer. 
2. In PC2, select Tools > Map Network Drive from pull down menu. 
3. Select X: from Drive combo box. 
4. Type in \\PC1\DATA in Folder prompt. (Remember to replace PC1 with the IP Address here. 

For example: \\192.168.18.18\data) 
5. A separate X:\ window will be opened, close it. 
6. In the Windows Explorer console, you will find X: appear on the left hand side. 
7. Click on the X: and you will see nothing in this network folder. 
 
 
Create a file in PC1 
 
1. In PC2, in the Windows Explorer console, right click on the detail pane in right hand side 

and select New > Text Document. 
2. Type in MyReport.txt and press Enter. 
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Change the permission in PC1 
 
1. In PC1, right click the Data folder in the Windows Explorer console. Select Sharing and 

Security… 
2. Select Security Tab. 
3. In the Group or user names: list box, highlight Administrator. 
4. In the Permissions for Administrator list box, select Deny Write. 
5. Click OK. 
6. In the Security dialog box, click Yes. 
 
 
Try to create file again in PC2 
 
1. In PC2, in the Windows Explorer console, right click on the detail pane in right hand side 

and select New > Text Document. 
2. You will see a error dialog box and stated that you are unable to create a file. 
 
 
Review 
 
This exercise demonstrates how to create a folder share in one computer and configure 
permission. It also states the procedure to map a network drive from one computer to another if 
permission is allowed. 
 
If time permitted, students can reverse PC1 and PC2 to perform the exercise again. 
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Exercise 4b: Printer Sharing in Peer-To-Peer Network 
 

Scenario 
 
You have two PCs and there is only one printer attached to one PC and you want to share the 
printer with the other PC. 
 

Detail Steps to perform exercise: 
 
This exercise requires two partners. Each partner must use the IPCONFIG command to obtain 
the computer’s IP Address before proceed the exercise. 
 
The partners determine which one is PC1 and which one is PC2. After obtained the IP Address, 
substitute the PC1 and PC2 names with your computer’s IP Address in the following steps. 
 
 
Install and Share a Printer in PC1 
 
1. In PC1, click Start > Printers and Faxes. 
2. Click Add a printer. 
3. In the Welcome to the Add Printer Wizard, click Next. 
4. In the Local or Network Printer dialog box, select Local printer attached to this computer 

and clear Automatically detect and install my Plug and Play printer. 
5. Click Next. 
6. In the Select a Printer Prot window, select Use the following port: LPT1 
7. Click Next. 
8. In the Install Printer Software dialog box, select HP in the manufacture column and HP 

LaserJet 5 in the Printers column. 
9. Click Next. 
10. In the Name Your Printer screen, click Next. 
11. In the Printer Sharing screen, select Share name and click Next. 
12. In the Location and Comment screen, click Next. 
13. In the Do you want to print a test page? Screen, select No and click Next. 
14. In the Completing the Add Printer Wizard dialog box, click Finish. 
15. You will see a printer installed after a while. Right click on the HP LaserJet 5 icon and select 

Properties. 
16. Review the Sharing Tab and Security Tabs. 
17. Click OK to close the dialog box. 
 
 
Map the Printer from PC2 
 
1. In PC2, click Start > Printers and Faxes 
2. Click Add a printer. 
3. In the Welcome to the Add Printer Wizard, click Next. 
4. In the Local or Network Printer dialog box, select A network printer or a printer attached to 

another computer. 
5. Click Next. 
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6. In the Specify a Printer dialog box, select Connect to this printer (or to browse for a printer, 
select this option and click Next). Type in \\PC1\HPLaserJ (Remember to substitute PC1 
with its IP Address). Click Next 

7. A dialog box appear and stated that You are about to connect to a printer in PC1 and a 
printer driver will be installed to your machine automatically. Click Yes to proceed. 

8. In the Completing the Add Printer Wizard dialog box, click Finish. 
9. You will see a printer installed after a while. 
10. You can now print to this network printer from your application. 
 
 
 
Review 
 
This exercise demonstrates how to share a printer in a peer-to-peer environment. It also states 
the procedure to map a network printer from a printer user computer. 
 
If time permitted, students can reverse PC1 and PC2 to perform the exercise again. 
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